/etc/profile:

export __GL_YIELD="USLEEP"
export MOZ_USE_OMTC=1
export KWIN_EXPLICIT_SYNC=0
export QSG_RENDER_LOOP=basic

/usr/share/X11/xorg.conf.d/20-nvidia.conf:

Section "ServerLayout"
    Identifier     "layout"
    Screen 1       "Screen0"
    Inactive       "intel"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    BusID          "PCI:1:0:0"
    Option         "CoolBits" "1"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    Option         "UseEdidDpi" "false"
    Option         "DPI" "88 x 88"
    Option         "DPMS" "off"
EndSection

Section "Screen"
    Monitor        "Monitor0"
    Device         "Device0"
    Identifier     "Screen0"
    DefaultDepth   24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "eDP-1-0"
    Option         "metamodes" "nvidia-auto-select @1920x1080 +0+0 { ForceFullCompositionPipeline = On }"
    SubSection     "Display"
        Depth       24
        Modes      "1920x1080"
    EndSubSection
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Update:

After installing nvidia-367, a /etc/X11/xorg.conf is created.
I added the ForceFullCompositionPipeline setting into it:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
    Option "metamodes" "nvidia-auto-select @1920x1080 +0+0 { ForceFullCompositionPipeline = On }"
EndSection
Advertisements